
Hello my name is Junior and I am no expert at this so I will do my best here, there are something I do not 

fully comprehend yet but hey we all have to start somewhere. After about 2 months I have successfully 

learned how to code my own car using an OBD to serial cable and NCS expert (2006 325i) Usually you 

have to install all these programs from a cd but I have compressed them directly from my hard drive and 

I think it should work this way. This setup assumes you are using an OBD interface there is a file in 

C:\ediabas\ediabas.ini that you can set which interface you would like to use.. a little more advanced 

Over-view 

1. Unzip “NCS EXPERT.rar” to C:\     

a. We are looking for three folders, EDIABAS, INPA and NCS EXPERT 

b.  folders should look like this 

 

2. Navigate to C:\INPA\BIN  

a. Right click on INPALOAD.exe and create a shortcut to desktop 

3. Navigate to C:\NCS EXPERT 

a. Create a shortcut to your desktop of the “WORK” folder 

4. Navigate to C:\NCS EXPERT\BIN 

a. Create a shortcut to desktop  of “NCSEXPER.EXE” 
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                                                                   Setting up and using NCS Expert:
This was originally written by Junior, Mark, and Revtor on various boards.  It has been modified to be specific to the E63-E64 models
 
- First you will need NCS Expert ver. 3.1.0.  It is a 96MB file zipped.  It will download as a .rar file, but can be opened with WinZip or Unrar 
- Follow these instructions to the letter. In step 1. where it says unzip NCS Expert.rar into C:\.  Do not unzip it into any other folder.  The scripts
are written to look for certian files in C:  Unless you are an expert in rewriting scripts, do not deviate from the instructions.
- The zip file actually has three programs embedded in it  NCS Expertentool ver 3.1.0; INPA Loader ver 5.0.2 and EDIABAS 6.4.3
                  paste in your browser          http://rapidshare.com/#!download|216tl|429882289|NCSEXPER.rar|100601   



5. Navigate to C:\Ediabas\hardware\OBD  and run the OBDsetup.exe. Your screen will look 

something like this, since I have ran this script previously it might look a little different the first 

time you run it. YOU MUST RESTART after this!! 

a.  

 

6. Right click on my computer > properties 

a. Windows 7  

i. Click on Advanced system settings 

ii.  click on Environment Variables 

US00L346
TextBox
and WinXP is similar 



 
iii. Highlight “Path”  and click edit 



 
iv. Add this to the end “;C:\ediabas\bin”  

 
v. Click ok and exit all windows to desktop 

7. From desktop press the WINDOWS KEY + R and type devmgmt.msc  or just type in to search 

8.                                
9. This will open device manager. 

a. Go to PORTS>  double click on com1 > port settings tab > advanced 
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9c.  Perform after step 9b.
       Now plug the cable in to your laptop.When you plug the connector into the laptop, it must be on COM1.  It will not work with any other 
       COM#. Highlight the + sign by PORTS>double click the USB Serial device>port settings and change
        the port to Com 1>save.  It may give you a pop up that there may be a conflict with other devices on COM1.  That's OK as 
        you will no be using any other device when you code the car. >Now go into the advanced tab>change if not alreday set to this
        Com Port number should be COM 1; receive and transmit bytes should both be 4096; latency timer change to 1; minimum 
        read and minimum write 0>OK>OK 



b. Ensure “use fifo uffers” option is marked and receive buffers and transmit buffers are 

both set to 8. Once that is finished press ok and exit all windows. 

10. Take a second, double check everything you just did. Trust me when I say you can’t skip steps! 

11. Connect your obd cable to car and computer we are going to test functionality with INPA. 

12. Put key in slot and press the START STOP button but not to start car. 

13. Go to desktop and click on “INPALOAD” (shortcut we created previously) 

a. Both circles are black then continue, if not double check all previous steps make sure 

serial is set to com1 

 
14. Select your chassis mine is E90 so press F9, you will get this box 

 
15. Select “Karosserie”  now you will see another menu to the right. Select “airbag” 

16. Press F5 to read status.. if it continues without any errors we are ready to run NCS Expert 
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Press twice so car Ign on, lights and climate off 
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COM1.   **Very important.  If you do not get black circles try a differnt USB slot on laptop.
Only one is COM1. Also, have cable plugged in and car in Ign mode before you open INPALOAD 
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Select E60 (Which may seem counter intuitive
    since we have E63's.  B                             
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E60 
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It will be in English and not German 
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I believe you select Seat Modules
 then airbag or any other option
You are merely testing the ability
to see a module 



17. Close INPA and start NCS EXPERT.exe from desktop shortcut.  

18. Follow instructions very very very carefully, you can screw up your car starting now. If you don’t 

know how to follow directions stop immediately . ok now for the fun part. 

19. Should start off looking like this..  

20.  
21. Remember to follow directions closely…. 

22. Select “File > Load profile > Expertmode > OK 

23.  
24. File > edit profile   password is “repxet” 



25.  
26. Select car-keymemory >  check all three boxes > press ok 

27. Click on “consistency check” should get this .. press ok 

28.  
29. Then select “FSW/PSW” 

30. Make sure both check boxes are checked and top part only has “from CVT” selected .. should 

look like this 

31.  
32. Press ok, select consistency check again.. if no errors then press ok 

33. File > save profile as > FZG4.PFL “mine is name GZG2.PFL” press ok 
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33a. Save it as the name it defaults to. 
Don't change the name 



34. Example 

 
35. File>edit profile>repxet>profile info>  set profile name to “FSW PSW MAN” 

36. We have just created a profile to write to car via a .man file.  Every time you start NCS expert 

you will need to load this profile. After you load the profile you will see options like this 

37.  
38. Select F1 > select F3 here we can choose our chassis. We are going to select E89 (again we are 

assuming you are working on an E90) 
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Note** I use and load the profile
default profil mit.....as the one I load.  It seems
to work better than the one created.  It needs
to be edited to look like step 30.  Both bottom
boxes require the x. Remember password is
repxet 
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E60                                
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E63-64.  Again this may seem counter intuitive but it is the correct procedure
 
The program seeks the modules loaded for an E60 via files in NCVS Expert known
as DATEN files.  Most of the modules are loaded in these files.  There is an update
to these files that I got from a helpful site in Moscow. I did update them in my DATEN
folder, but so far do not see any differenmce, so for now use what comes with 
NCS Expert 



39.  
40. Press ok. Now it is asking which computer we want to code.. we are going and always select 

“CAS” press ok. All options will gray out for a couple seconds and then it will look like this. 

41.  
42. Notice that now our vin is there along with “FA” FA is like a single string that tells the car 

everthing that it came with from the factory. More advanced users can change this but not 

really needed. I have provided a pdf for that if you are interested.  

43. Now select “F6” for back will gray out then will look like this  
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E60 is the one to highlight 
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E89 
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Note* CAS is not the 
comfort access module.
It is a coding reference
Coincidentally, there is
a module called CAS, which
is in fact the comfort access
module.  In case you were
wondering 
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E60 
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FG is your VIN 
FA will say E60 
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j 

US00L346
Cross-out

US00L346
TextBox
This may take a minute.  Do not interrupt. 



44.  
45. We are going to start by making a backup of the car. 

46. WARNING this initial step will reset your ECU and replace any settings you have coded 

previously since we have just “coded nothing” to the ECU. 

47. The whole point of this was for the ECU to read all the settings from every module and place 

them in a file called FSW_PSW.TRC. 

48. Navigate to the “WORK” shortcut we created on the desktop. 

49. Open the file FSW_PSW.TRC with notepad.  Make a copy of it in a safe place. This is your backup 

of all the settings. 

50. Ok  now for the fun.. coding..  lets code the famous “digital speed on cluster” 

51. Just to avoid any mistake close NCS we are going to start from the beginning. 

52. Load NCS >File>load profile “FSW PSW MAN” 

53. F1>F3>select your chassis>select “CAS”   

54. Press F6 for back 

55. Press F4 to select a specific module “process ecu” then you get a list of all modules on your car.. 

will and may be different. 

56.  
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E63 (or E64) followed by E60 
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E60 
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Step 49 saves a master file of
all your modules and settings.
Save this on a thumb drive as well
as on the PC in the backup folder
Name it something other than
FSW_PSW.TRC, like Master.TRC 



57. Select “CAS”  then select “READ ECU” this is going to create another FSW_PSW.TRC  file but only 

with the values on for the module we select. 

58. Select “READ ECU” this will read all the values from the specific module and place ten in the file 

stated above. You will get a screen like this.. you can close it. 

59.  
60. Leave ncs open and head to the “work” folder.  

61. Open the FSW_PSW.TRC file with notepad 

62. File>save as FSW_PSW.MAN (be sure to select  “save as type” to all files so that it will accept our 

“.MAN” extension. If you fail to do so it will just save it as a text file  .TXT 

63. The “FSW PSW MAN” profile that we used is going to use this “FSW_PSW.MAN” file .  this is 

where we are going to make any changes and then NCS will write this to ECU. 

64. Open the file we just saved with notepad will look like this. 
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Note* very important to save as a .MAN 
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65.  
66. The basics are if an option is enabled it will say “aktiv” if its not it will say “nicht_aktiv” 

67. Search for the option “BC_DIGITAL_V” and change the value from “nicht_aktiv” to “aktiv” 

68. File >save 

69. Back to NCS now hit F5 for basic functions 

70. Select “coapiReadSgGetFswPsw” and ok..  you are basically telling NCS to read all the values 

from your fsw_psw.man file. You will see a screen similar to this just press ok. 

71.  
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You can use Edit>Find to get to the line of code quicker
example  Edit>Find>bc
 
It will take upi to every line that has a bc in it.  When you
get to the line that has bc_digital_v, thats where you change
nicht_aktiv to aktiv, then save as FSW-PSW.MAN  all Caps
 
**You can only have one .MAN file in the work folder at a time 
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E60 



72. Then you should get this. 

73.  
74. Press ok. 

75.  Ok now take a look where it says “JOBNAME = CODIERDATEN_LESEN”  

76. We need to change that to a coding function because we want to write the changes to the 

module. 

77. Select F2 “job”  select SG_CODIEREN and press ok 

78. Then press F3 to execute the job. Will gray out for some time..  now you will see this . notice the 

“coding ended’ message 

79.  
80. Assuming no errors.. CONGRATS you now have digital speed .  

81. Press the BC button to scroll by MPG, MLS and MPH eventually you will see “V= 0 mph”.. 

82. After a couple of times you will get used to the process.. to code other options you just have to 

know which module controls them. Which value or values to change. Always do your research. 

83. I know this is long as hell I tried to be as descriptive as possible. If this helped you in any way 

please make a donation as I am offering this knowledge free    

84. Any questions visit E90post.com!   
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E63 (E60) 
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E60 
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This is as descriptive as possible. Post all questions on this thread so everyone can see and we can share our learnings together
 
Happy Coding                 
 


